V2.9a fixes the noise graph plotting problem

classic Classic list List threaded Threaded
8 messages Options
Rob
Reply | Threaded
Open this post in threaded view
|

V2.9a fixes the noise graph plotting problem

Rob
To install 2.9a and get noise graphing working:

1) Stop WD:                             "./wsprdaemon.sh -z"
2) clean your signal_level logs:  "rm -rf signal_levels/"  (sorry, but you WILL loose your logs)
3) get 2.9a:                              "git pull"
4) start WD:                              "./wsprdaemon.sh -z"

I am not aware of any other bugs in 2.9 which need to be fixed
Reply | Threaded
Open this post in threaded view
|

Re: V2.9a fixes the noise graph plotting problem

Powernumpty
Typo?
4) start WD:                              "./wsprdaemon.sh -a"

Cheers
Stu
Rob
Reply | Threaded
Open this post in threaded view
|

Re: V2.9a fixes the noise graph plotting problem

Rob
Yes, a typo:  'wd -a' starts WD
thanks
Reply | Threaded
Open this post in threaded view
|

Re: V2.9a fixes the noise graph plotting problem

Ulli
I have installed V2.9a now...
I can see my noise plots created: http://wsprdaemon.org/graphs/ON5KQ/

However how can I see the graphs in the Grafana Dashboard ? It says "no data"...
https://grafana.int8.com/d/3dcOdAmWk/calibrated-noise-dashboard?orgId=1&from=now-24h&to=now&refresh=1m&var-site=ON5KQ&var-receiver=All&var-band=All

Do I need to build the dashboard myself following the guide from Gwyn on the website ?
I have installed Grafana now and start learning.... looooooooong way to go, for an IT-Idiot like me...

Ulli, ON5KQ
Rob
Reply | Threaded
Open this post in threaded view
|

Re: V2.9a fixes the noise graph plotting problem

Rob
The grafana.int8.com site is no longer in use.
Gwyn has recently updated the TS and Grafana documents to show how to use the new TS database.
I think there is a 'open' user which you can use on the new server, but Gwyn is really in charge of this aspect of WD.
Reply | Threaded
Open this post in threaded view
|

Re: V2.9a fixes the noise graph plotting problem

Ulli
In understand - his tutorials on Grafana are excellent - my learning curve is however too slow (old style..)

One thing I always have problems with is that the wsprdaemon.log file gets bombed with this since I started using WD with version 2.5a

Traceback (most recent call last):
  File "/tmp/wsprdaemon/noise_plot.py", line 69, in <module>
    noise_vals = genfromtxt(csv_file_path, delimiter=',')[:,1:]  
IndexError: too many indices for array
mv: cannot stat '/tmp/wsprdaemon/wd_tmp.png': No such file or directory

I don't understand the code at all, but I guess, it shouldn't be there... I get it all the time...
I think I better re-install the whole system ?!
But even that I have done several times, without succes...

Any advice ?
What does it mean ?

Ulli, ON5KQ

Have now appox 20m of wire connected to a single kiwi, just to do something...
Rob
Reply | Threaded
Open this post in threaded view
|

Re: V2.9a fixes the noise graph plotting problem

Rob
You can ignore those error lines if they appear only once at WD startup.
I'll put fixing that on the TODO: list of 2.9x

On Tue, May 12, 2020 at 11:45 AM Ulli [via wsprdaemon] <[hidden email]> wrote:
In understand - his tutorials on Grafana are excellent - my learning curve is however too slow (old style..)

One thing I always have problems with is that the wsprdaemon.log file gets bombed with this since I started using WD with version 2.5a

Traceback (most recent call last):
  File "/tmp/wsprdaemon/noise_plot.py", line 69, in <module>
    noise_vals = genfromtxt(csv_file_path, delimiter=',')[:,1:]  
IndexError: too many indices for array
mv: cannot stat '/tmp/wsprdaemon/wd_tmp.png': No such file or directory

I don't understand the code at all, but I guess, it shouldn't be there... I get it all the time...
I think I better re-install the whole system ?!
But even that I have done several times, without succes...

Any advice ?
What does it mean ?

Ulli, ON5KQ

Have now appox 20m of wire connected to a single kiwi, just to do something...


If you reply to this email, your message will be added to the discussion below:
http://wsprdaemon.224604.n8.nabble.com/V2-9a-fixes-the-noise-graph-plotting-problem-tp21p26.html
To unsubscribe from V2.9a fixes the noise graph plotting problem, click here.
NAML


--
Rob Robinett
AI6VN
mobile: +1 650 218 8896
Rob
Reply | Threaded
Open this post in threaded view
|

Re: V2.9a fixes the noise graph plotting problem

Rob
I just checked in V2.9b with fixes to suppress those spurious startup errors  along with some other low risk error checking.  Users of 2.9a need not upgrade to 2.9b.